UPDATED: Customer Advisory: Microsoft Windows 10 version 1903 on Workspot Cloud Workstations (September 12, 2019)

Robert Plamondon -

Update: September 12, 2019

Resolution

Workspot has a fix for this issue, which will be released with the Workspot Agent 2.4.1. This is currently in beta and will be released soon.

Root Cause Analysis

Moving from one version of Windows to the next is equivalent to a new operating system installation, with the installation process first backing up and then restoring critical components. One of the components is the secure credential store. The Workspot Agent uses this location to store critical information used to ensure secure communications with Control. During the update process, this information can be corrupted.

 


 

Description

After a Workspot desktop is updated to the latest Microsoft Windows 10 (version 1903) from a previous version of Windows 10 (for example, 1709, 1803, or 1809), the Workspot Agent is unable to communicate with Workspot Control.

If this happens to one of your Workspot VMs, Workspot Control will show its status as “Offline” after the Windows 10 update.

 Note: This issue does NOT affect VMs created from a Windows 10, version 1903 base image. It is a side effect of the update process. 

Recommendations

  1.  If you do not need to update your existing VMs to Windows 10, version 1903 immediately, please defer updating. (Security patches for previous Windows 10 versions should be installed as normal.)
    • If you are using persistent desktops, you need to disable automatic Windows Update within your VM settings or Windows image management tool, such as SCCM.
    • If you are using non-persistent desktop, defer updating your templates to version 1903.
  2.  If you need to update your existing VMs (persistent or nonpersistent) to Windows 10, version 1903, please contact your Workspot Customer Success Manager and we will work with you to ensure that your update is successful.
  3.  If you have already updated your VMs to Windows 10, version 1903, and did not experience any issues, then please send your Workspot Customer Success Manager an email letting him/her know that you were successful.

 Additional Details

The Workspot VM shown as “Agent Offline” in Workspot Control, but “Desktop Details” will show “Azure VM Status” as “Running.”

 win1903-bug-1.png

 Win1903-bug-2.png

  1. If a persistent desktop auto-updates to version 1903, Control may see it as unavailable, but its assigned user can still connect to it and use it normally.
  2. If a non-persistent desktop auto-updates to version 1903, Control will see it as unavailable and it will not be available to users.

Workarounds

Non-persistent desktops

  1. Disable automatic updates.
  2. For each desktop in “Error” status, use the “Redeploy VM” button at “Resources > poolname > desktopname > Redeploy VM.”

Persistent desktops

  1. Disable automatic updates.
  2. Persistent desktops can be reconnected to their pools with the assistance of Workspot Customer Success.

 

Have more questions? Submit a request

Comments

Powered by Zendesk