Workspot Hardware and System Requirements

Robert Plamondon -

Workspot Control Browser Support

See the release notes for the latest version of Workspot Control.

 

Workspot Clients

Hardware and OS requirements for the Workspot Client are listed below:

Supported Hardware and Operating Systems

OS

Versions

Other Requirements

Windows

 

8, 10

Use the correct version (32-bit or 64-bit) for the client OS.

Dual-core CPU or better

4 GB RAM minimum

Remote Desktop Client running RDP v. 8.1 or higher is required. This will be present by default on systems running Microsoft's latest updates, or can be downloaded from Microsoft.

Windows 7 is no longer supported. See EOL/EOS Announcement: Workspot Client on Windows 7.

MacOS

10.12 Sierra

10.13 High Sierra

10.14 Mojave

10.15 Catalina

(macOS 10.12 is supported through Mac Client 3.2.2 only)

All version require dual-core CPU or better, 4 GB RAM minimum

iOS

 

iOS 10 and up

Supported on all devices running these OS versions

 

Android

5.0.2 Lollipop

6.0.1 Marshmallow

7.x Nougat

8.x Oreo

9.x Pie

Android 10

Supported on devices running these OS versions

Thin Clients
See Thin Client Device Considerations

 

Workspot Enterprise Controller, RD Pools, and RD Gateway

Windows Server 2012R2 and Windows Server 2016.

Remote Desktop Services 2012R2, 2016, and 2019.

Workspot Agent

Desktop Operating Systems: Windows 8.1 and Windows 10

Servers: Windows Server 2012R2 and up.

Have more questions? Submit a request

Comments

Powered by Zendesk